
Roadway’s CompBook 

From the Start  

The template file for Roadway’s CompBook will be downloaded from the Roadway Design Homepage or just click HERE. From the 
Roadway Homepage click on the Templates link and then select the Access Database Templates link. Here you will see English and 
Metric CompBook files. Select the appropriate link and your web browser will prompt you for the path to save the zip file on your 
computer. Unzip(extract) the .mdb file from the zip file. We recommend renaming the .mdb file to TIP#.mdb. You may customize the 
name to fit your needs to indicate preliminary or final estimate. It’s up to you!  

Invoking Comp Book Forms  

A Geopak application will take your SDF output file you created through D&C manager and import it into the CompBook file you saved 
to your hard drive. 

Open a MicroStation design file. From the MicroStation pulldown menu, select Applications>GEOPAK ROAD>Launch Comp Book 
Forms. The following dialog should appear: 

 

Note that Comp Book Forms is not a MicroStation application, therefore exiting MicroStation will not deactivate this application. You 
must close this separately. 

Selecting Your Project  

 

To open your project select from the pulldown menu File>New Project… or press the New Project icon. The following dialog will 
appear: 



 

Press ADD to invoke the Database Selection dialog. Select the TIP#.mdb file and press Open. If an old database name appears, 
highlight the old database and select Delete before you add your new database. 

 

The TIP#.mdb database name now appears in the database manager window. 

 

Close the Database Manager window by pressing the X in the upper left-hand corner. The name of your database is the default name 
of your project and is now shown in the Construction Manager Window. 

 

Importing Quantities (SDF files)  



The SDF file you created through D&C Manager can now be imported into the current project/database. Select from the pulldown menu 
File>Import>Comp Book. The Import Computation Dialog appears. 

 

Use the "… " button to navigate to and select the SDF file containing your quantities. Select the options as seen above. Press the OK 
button to begin import. A progress bar will appear. Once the progress bar disappears, exit out of GEOPAK Construction Manager 
window. 

Welcome to Roadway’s CompBook  

CompBook will take the quantities from your SDF file and fill out your calculation sheets for you to print out. 

From your explorer window, open your TIP#.mdb file. When your file opens you will see the Main Switchboard. 

 

 Always use the squares to the left of the descriptions. Select Table Options. 

 



From the Table Options switchboard, select Create RdyCompBook. There will be a couple of message windows stating that the existing 
Rdy_compbook will be deleted and that you are pasting xxx number of rows. Answer Yes to both of these. Note: See below 
documentation on Append RdyCompBook and Replace a Pay Item before using these options. 

Select Return to Main SwitchBoard. Upon returning to the Main Switchboard, select Utilities. 

 

From this Utilities switchboard, select Project Information. You will now see the proj_info Form. 

 

Enter the requested information and press the Close Form button. This will in turn fill in the same information on your computation 
sheets. From the Utilities switchboard, select Return to Main SwitchBoard. 

 

From the Main SwitchBoard, select Pay Items. This will bring up your Main Pay Items switchboard. 

Calculation Sheets  

Now you’re ready to start generating your computation sheets. Select the buttons that correspond to the pay items that is included on 
your project. Some buttons will invoke other windows that will have more pay items available. The forms will look similar to the 
Driveway form shown below: 



 

Enter the percentage into the % field by which you would like to increase the Total shown. The number that displays to the right of the 
% field is increased by this percentage. Use this number to help you generate your SAY figure and then enter this SAY quantity in the 
empty SAY field.  

NOTE: You must always enter a SAY quantity even if you are not increasing the total that was originally computed. For example, if the 
calculations show that you have 2 GRAU-350 anchor units, you must re-enter the 2 in the SAY field. 

You may have to enter the Section number yourself. After you have entered your Say quantity, print your form using the Print Form 
button and then close the form by the Close Form button. 

There are forms for pipes and guardrail anchor units, etc. that you can print if you want to but these will not be turned in to plan 
checking. They are for your use only but you still must enter the say quantity before closing them. 

Transport  

When you have entered say quantities for all of your pay items, you can export a file that will easily be imported into Transport. From 
your Main Switchboard menu select the Utilities option again. From here, select the Transport Export 

Option. A message box will appear stating that "Transport.txt has been created successfully." Click ok and you can exit your TIP#.mdb 
file.  

Now, just import the Transport.txt file into Transport and you have the majority of your estimate done for you! 

Append RdyCompBook  



The Append option should be used only if you are adding a new pay item or a new occurrence of an existing pay item. For example, if 
you add a new pipe to your project, you will need to append your original data. Fence only the new pipe, create a new output file, and 
run the calculations through D&C. This new output file contains only the new pipe. Then Launch CompBook Forms to import your new 
output file into your existing TIP#.mdb file. Upon completing the import process, reopen your TIP#.mdb file and go to Table 
Options>Append RdyCompBook. This process adds your new pay item to the RdyCompBook Table. 

Replace a Pay Item  

The Replace option should be used if you modify an existing pay item. For example, if you lengthen guardrail you will use this option. 
Recalculate all the guardrail again and create a new output file that contains only your guardrail. Then Launch CompBook Forms to 
import your new output file into your existing TIP#.mdb file. Upon completing the import process, reopen your TIP#.mdb file and go to 
Table Options>Replace a Pay Item. Enter the exact pay item number that you wish to delete and press OK. For English Steel Beam 
Guardrail you will enter 3030000000-E.  

 

This process deletes the old information for the pay item you entered and replaces it with your new calculations. 
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Invoking Comp Book Forms 


A Geopak application will take your SDF output file you created through D&C manager and import it into the CompBook file you saved to your hard drive.


Open a MicroStation design file. From the MicroStation pulldown menu, select Applications>GEOPAK ROAD>Launch Comp Book Forms. The following dialog should appear:
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Note that Comp Book Forms is not a MicroStation application, therefore exiting MicroStation will not deactivate this application. You must close this separately.


Selecting Your Project 
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To open your project select from the pulldown menu File>New Project… or press the New Project icon. The following dialog will appear:
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Press ADD to invoke the Database Selection dialog. Select the TIP#.mdb file and press Open. If an old database name appears, highlight the old database and select Delete before you add your new database.
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The TIP#.mdb database name now appears in the database manager window.
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Close the Database Manager window by pressing the X in the upper left-hand corner. The name of your database is the default name of your project and is now shown in the Construction Manager Window.
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Importing Quantities (SDF files) 


The SDF file you created through D&C Manager can now be imported into the current project/database. Select from the pulldown menu File>Import>Comp Book. The Import Computation Dialog appears.
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Use the "… " button to navigate to and select the SDF file containing your quantities. Select the options as seen above. Press the OK button to begin import. A progress bar will appear. Once the progress bar disappears, exit out of GEOPAK Construction Manager window.


Welcome to Roadway’s CompBook 


CompBook will take the quantities from your SDF file and fill out your calculation sheets for you to print out.


From your explorer window, open your TIP#.mdb file. When your file opens you will see the Main Switchboard.
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 Always use the squares to the left of the descriptions. Select Table Options.
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From the Table Options switchboard, select Create RdyCompBook. There will be a couple of message windows stating that the existing Rdy_compbook will be deleted and that you are pasting xxx number of rows. Answer Yes to both of these. Note: See below documentation on Append RdyCompBook and Replace a Pay Item before using these options.


Select Return to Main SwitchBoard. Upon returning to the Main Switchboard, select Utilities.
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From this Utilities switchboard, select Project Information. You will now see the proj_info Form.
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Enter the requested information and press the Close Form button. This will in turn fill in the same information on your computation sheets. From the Utilities switchboard, select Return to Main SwitchBoard.
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From the Main SwitchBoard, select Pay Items. This will bring up your Main Pay Items switchboard.


Calculation Sheets 


Now you’re ready to start generating your computation sheets. Select the buttons that correspond to the pay items that is included on your project. Some buttons will invoke other windows that will have more pay items available. The forms will look similar to the Driveway form shown below:
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Enter the percentage into the % field by which you would like to increase the Total shown. The number that displays to the right of the % field is increased by this percentage. Use this number to help you generate your SAY figure and then enter this SAY quantity in the empty SAY field. 


NOTE: You must always enter a SAY quantity even if you are not increasing the total that was originally computed. For example, if the calculations show that you have 2 GRAU-350 anchor units, you must re-enter the 2 in the SAY field.


You may have to enter the Section number yourself. After you have entered your Say quantity, print your form using the Print Form button and then close the form by the Close Form button.


There are forms for pipes and guardrail anchor units, etc. that you can print if you want to but these will not be turned in to plan checking. They are for your use only but you still must enter the say quantity before closing them.


Transport 


When you have entered say quantities for all of your pay items, you can export a file that will easily be imported into Transport. From your Main Switchboard menu select the Utilities option again. From here, select the Transport Export


Option. A message box will appear stating that "Transport.txt has been created successfully." Click ok and you can exit your TIP#.mdb file. 


Now, just import the Transport.txt file into Transport and you have the majority of your estimate done for you!


Append RdyCompBook 


The Append option should be used only if you are adding a new pay item or a new occurrence of an existing pay item. For example, if you add a new pipe to your project, you will need to append your original data. Fence only the new pipe, create a new output file, and run the calculations through D&C. This new output file contains only the new pipe. Then Launch CompBook Forms to import your new output file into your existing TIP#.mdb file. Upon completing the import process, reopen your TIP#.mdb file and go to Table Options>Append RdyCompBook. This process adds your new pay item to the RdyCompBook Table.


Replace a Pay Item 


The Replace option should be used if you modify an existing pay item. For example, if you lengthen guardrail you will use this option. Recalculate all the guardrail again and create a new output file that contains only your guardrail. Then Launch CompBook Forms to import your new output file into your existing TIP#.mdb file. Upon completing the import process, reopen your TIP#.mdb file and go to Table Options>Replace a Pay Item. Enter the exact pay item number that you wish to delete and press OK. For English Steel Beam Guardrail you will enter 3030000000-E. 


[image: image14.png]





This process deletes the old information for the pay item you entered and replaces it with your new calculations.


